Action Required: Critical worldwide PHP security update (php2shell), please upgrade PHP

3 posts by 2 authors in: Forums > CMS Builder
Last Post: Friday at 2:56pm   (RSS)

Hi everyone,

Just a heads up, you may have already heard about this. This week, PHP released fixes for two critical security issues called php2shell (CVE-2026-109618 and CVE-2026-109619). They let someone run their own code on your server, with no login, just by sending a request to a PHP page. Attack attempts have already been reported.

This is a bug in PHP itself. It has nothing to do with CMS Builder or any other website software. If your server runs PHP and has even one PHP file accessible from the web, it's affected, no matter what else is on it.

This is the most serious PHP security issue we've seen in over 10 years.

What to do: upgrade PHP to one of these versions or newer:

  • PHP 8.5.12
  • PHP 8.4.27
  • PHP 8.3.36
  • PHP 8.2.35

PHP 8.1 and older are end-of-life, so there's no official release with this fix. The PHP team published fix code for 7.4, 8.0, and 8.1 for people who build PHP themselves, and some hosts and support vendors provide patched versions. If you're on 8.1 or older, upgrade to 8.2 or newer, or check with your host to confirm you're running a patched version.

If you're on shared hosting or aren't sure what you're running, check with your hosting provider. You can see your PHP version in CMS Builder under: Admin → General Settings → Server Info

If you manage your own server: Plesk and cPanel each run their own separate copy of PHP for the control panel, and updating your website PHP doesn't update it. Make sure you're running the latest control panel update, and restart your server after you update.

More details are on the PHP site: https://www.php.net/archive/2026.php#2026-10-21-5

Let me know any questions.

Thanks!

Dave Edis - Senior Developer
interactivetools.com

Hi Kenny,

Thanks for posting this, and for the detailed write-up. Your post was actually the first place I saw it.

I've confirmed it on php.net. Their Oct 23 notice says the Oct 21 releases don't fix this one. The fix and the full advisory will come in PHP's next regular release, and until then they haven't published how the issue works: https://www.php.net/archive/2026.php#2026-10-23-1

Here's a patch anyone can apply now to be extra safe, and we'll include it in the next release as well.

In cmsb/lib/SessionHandler.php, search for this line:

ini_set('session.serialize_handler', 'php');

And replace it with this:

// CVE-2026-115560: temporary workaround until servers install PHP's fix.
// Reference: https://www.php.net/archive/2026.php#2026-10-23-1
// Attackers could potentially run code, but only when all three of these are true:
// - phpinfo() shows session.serialize_handler as php_serialize or php_binary (not the default, php)
// - the line below switches it to php
// - session.upload_progress.enabled is on, which is PHP's default
// Once most servers run a PHP version that fixes this CVE, delete this note and uncomment the line below.
//ini_set('session.serialize_handler', 'php'); // Use PHP's built-in session serialization

On servers where session.serialize_handler isn't set to php, existing sessions won't load after this change, so users will need to log in again once. Servers using PHP's default won't notice any difference. Versions before v3.67 don't have this line and don't need the patch.

Setting session.upload_progress.enabled = 0 server-wide, as you described, is still a good idea. It also covers one of the php2shell issues on servers that haven't been updated yet.

Thanks again for the heads up! Let me know any questions or more news.

Dave Edis - Senior Developer
interactivetools.com